Bug when using php version older than 4.1.0

Discovered a bug? If not sure, please post question in the support forum.

Bug when using php version older than 4.1.0

Postby rolf » Tue May 14, 2002 7:50 pm

We have received 2-3 emails from people that used a php version older than 4.1.0. They had problems using any builds after 112.

Our script uses some of the new variables that was introduced in PHP version 4.1.0. ($_GET, $_POST, $_COOKIE, $_SERVER and $_ENV) They deprecate the old $HTTP_*_VARS arrays. In addition to be much shorter to type - these variables are also available regardless of the scope, and there's no need to import them using the 'global' statement. (Andi & Zeev) http://www.php.net/ChangeLog-4.php

Our new build will have this problem fixed, by converting the old HTTP_* to the new ones. Check out changes/download page for when this is fixed. www.kplaylist.net/?download=1

Note!: www.php.net announced 27.feb.02: "All users of PHP are strongly encouraged to either upgrade to PHP 4.1.2, or install the patch".

Everybody with this problem should upgrade php to a newer version :!:
rolf
 

Re: Bug when using php version older than 4.1.0

Postby aba » Wed May 15, 2002 2:52 pm

rolf wrote:Note!: www.php.net announced 27.feb.02: "All users of PHP are strongly encouraged to either upgrade to PHP 4.1.2, or install the patch".


Versions prior to PHP 4.1.2 includes a nasty security issue. Read
it about it here: http://security.e-matters.de/advisories/012002.html

However, users who are experiencing problems when using kPlaylist on any of the releases under the major 4 version should contact us. (Please do so with the full PHP error logs. You can enable logging to a file by editing the php.ini file, and restart apache if applicable.)

Åge
aba
Site Admin
 
Posts: 2325
Joined: Wed May 08, 2002 9:19 am


Return to Bugs



cron